Random freezes?

FencerFencer Senior
edited 6:38PM in Bugs/Support
Every 10 minutes or so on average, the game freezes for about one second. It flows perfectly apart from that. It's the only 3D application I've tried on this computer that exhibits this behavior.

Running Windows 8 with a quad core cpu. Any ideas?
you break all my thing you KILL my family, you knoeckd over my scanner

Comments

  • Echo of the pastEcho of the past Members, Senior
    edited October 2013
    I encounter this problem with most games on my low end laptop. From what I understand, it's caused by the game not having enough RAM to work with. Please post your other system specs.
  • SpirrwellSpirrwell That Guy Members
    edited October 2013
    If PVKII can run perfectly fine on an old Pentium 4 which can only have so much RAM, I sincerely doubt that the problem is not having enough RAM. But yes, do post your system specs.

    Try going into the console and typing "mat_queue_mode 0" without quotes... Though I think it would work with quotes, but whatever. If you don't know how to get to the console, go to Options->Advanced and check "Enable developer console."

    Then press the tilde key (the key that's usually just below the ESC key) and you should see a big box pop up where you can type the command I said.

    You may already know about the console, I just put the instructions there for anybody else. What this command will do is disable multicore rendering. Currently, multicore rendering is unstable and why it's been enabled by default, I have no idea. After typing in the command, play a while and see if it freezes. If this doesn't work, you can try validating the game cache. But first, try what I said.
    5GY1DFV.png


    ░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░████████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░██████░░░░██░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░░░████░░█████░░░██
    ░░░░░░███░░░░░░░░░░░░░░████░░█████░░░███
    ░░░░░░░░░░░░░░░░░░░░░░░░██░░░░░░████░░█████░░░████
    ░░░░░░░░░░░░░░░░░░░█████████░░███████████░░████
    ░░░░░░░░░░░░███████████████████████████░░░░░░██
    ░░░░░░░░░██████████████████████████████░░░░░░██
    ░░░░░░░█████████████████████████████████░░░░░░██
    ░░░░░██████████████████████████████████░░░░░░███
    ░░░░░███████████████████████████████████░░░░░████
    ░░░░████████████████████████████████████░░░░░████░░
    ░░░░███████████████████████████████████░░░░█████░░░
    ░░░░█████░░░░░░░░████████████████████░░░░██████░░░░
    ░░░░░██░░░░░░░░░░████████████████████████████░░░░░░
    ░░░░░░░░░░░░░░░░░██████████████████████████░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░████████████████████░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░█████████████░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░████████░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░████████░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░██░░░░░░░███████░░░░░░█████████░░░░░░░░░
    ░░░░░░███░░░███████░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░███████████░░░░░░░░░░░░░░░░░███░░░░░░░░░░░░░
    ░░░████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░████░░░░░░░░░░░░░░░░░░░░░░░░░░██████░░░░░░░

    yP71cHI.gif

    Xxkr2il.jpg
    56JtqQq.jpg
    kJFRh1a.png
    MOBO: MSI Z87M GAMING
    CPU: Intel® Core™ i7-4770K OC'd @ 3.7 GHz
    GPU: EVGA GTX 660 Ti
    RAM: Ripjaws X 8GB (2 x 4GB) DDR3 2133MHz
    OS: Windows 10 Technical Preview

  • Echo of the pastEcho of the past Members, Senior
    edited October 2013
    You can also try forcing pvk to run on 1 core. While the game is running, open task manager, right click on hl2.exe and click on "Set Affinity". Then, in the window that appears, only select one of the cores and click OK.
  • FencerFencer Senior
    edited October 2013
    Ok, I have a Core i7 processor with 8 gigs of RAM.

    I checked the resource monitor after a freeze specifically for this and my system only peaked at about 3.7 gigs usage. The freezes happen just as often in low stress situtations (running alone through a cave) as well as in the heat of battle. I have 60+ fps at any time, there is no framerate drop except for complete freezes for 1 second.

    Tried the mat_queue_mode 0 and manually setting to 1 core like suggested, still freezing :(
    you break all my thing you KILL my family, you knoeckd over my scanner
  • DinahDinah Skirmisher's wench PVKII Team
    edited 6:38PM
    What version of windows 8 do you have?
    LOLIWDIT_zpsec1f606c.jpeg
    Agsma is me from the future
  • FencerFencer Senior
    edited October 2013
    Windows 8.0 x64

    Version 6.2 (Build 9200)
    you break all my thing you KILL my family, you knoeckd over my scanner
  • SpirrwellSpirrwell That Guy Members
    edited 6:38PM
    I'm pretty sure the Windows version is also irrelevant. I used to have that problem all the time and I'm running Windows 7. Sometimes it will leave me alone for a while though, seems to have disappeared for the time being for a while. Like I said, try verifying the integrity of the game cache. And, as much as I hate doing this, because I've done it so many times myself, you can try re-downloading it.

    Also, something I should've thought of first, make sure your video card drivers are updated. I always recommend getting them directly from its respective website.
    5GY1DFV.png


    ░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░████████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░██████░░░░██░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░░░████░░█████░░░██
    ░░░░░░███░░░░░░░░░░░░░░████░░█████░░░███
    ░░░░░░░░░░░░░░░░░░░░░░░░██░░░░░░████░░█████░░░████
    ░░░░░░░░░░░░░░░░░░░█████████░░███████████░░████
    ░░░░░░░░░░░░███████████████████████████░░░░░░██
    ░░░░░░░░░██████████████████████████████░░░░░░██
    ░░░░░░░█████████████████████████████████░░░░░░██
    ░░░░░██████████████████████████████████░░░░░░███
    ░░░░░███████████████████████████████████░░░░░████
    ░░░░████████████████████████████████████░░░░░████░░
    ░░░░███████████████████████████████████░░░░█████░░░
    ░░░░█████░░░░░░░░████████████████████░░░░██████░░░░
    ░░░░░██░░░░░░░░░░████████████████████████████░░░░░░
    ░░░░░░░░░░░░░░░░░██████████████████████████░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░████████████████████░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░█████████████░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░████████░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░████████░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░██░░░░░░░███████░░░░░░█████████░░░░░░░░░
    ░░░░░░███░░░███████░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░███████████░░░░░░░░░░░░░░░░░███░░░░░░░░░░░░░
    ░░░████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░████░░░░░░░░░░░░░░░░░░░░░░░░░░██████░░░░░░░

    yP71cHI.gif

    Xxkr2il.jpg
    56JtqQq.jpg
    kJFRh1a.png
    MOBO: MSI Z87M GAMING
    CPU: Intel® Core™ i7-4770K OC'd @ 3.7 GHz
    GPU: EVGA GTX 660 Ti
    RAM: Ripjaws X 8GB (2 x 4GB) DDR3 2133MHz
    OS: Windows 10 Technical Preview

  • FencerFencer Senior
    edited 6:38PM
    Video drivers are up to date, and I've recently logged about 50 hours in another game without it freezing once. Gonna try the validation and reinstall part now.
    you break all my thing you KILL my family, you knoeckd over my scanner
  • FencerFencer Senior
    edited 6:38PM
    Ok I verified the cache and played around with the console settings (cl_interp etc) and the problem is gone now! Thanks :icon_viking2:
    you break all my thing you KILL my family, you knoeckd over my scanner
Sign In or Register to comment.