Recent Update Causing Crash

Hi. Not sure if this is the right place for this (if not, my apologies and thanks to anyone who can point me in the right direction). The recent update seems to have killed my ability to play PVKii. I hadn't played for a few months, but I just loaded it up after updating the game. 

Details: I'm able to load up to the main menu. At this point the steam community tab becomes inaccessible (although that's small potatoes and could be a separate issue). From here, I'm able to select a server. There is a long load screen, and then the game crashes to desktop. I've tried it about a dozen times, with the same result for each. One time I was able to load into the game, but couldn't move and then the server crashed anyway. 

Two of my friends have run into the same problem, so it doesn't seem to be isolated to me. We're all on Macs, and for all of us it started after the recent update. 

No idea how to troubleshoot this one on my own, but if anyone can help me figure this out I would be extremely grateful. Love the game, and I'd love to keep playing it. 

Comments

  • Exactly same problem here, also on Mac :/
  • SpirrwellSpirrwell That Guy That Knows Things About a Lot of Things PVKII Team, Authorized Creator
    I've tested, and I can confirm the crash. It doesn't seem to happen if I create a game, but it does happen if I join a game. If either of you can confirm that as well, I'd appreciate it.

    I'll look into the issue some more. It's an odd crash.
    5GY1DFV.png


    ░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░████████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░██████░░░░██░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░░░████░░█████░░░██
    ░░░░░░███░░░░░░░░░░░░░░████░░█████░░░███
    ░░░░░░░░░░░░░░░░░░░░░░░░██░░░░░░████░░█████░░░████
    ░░░░░░░░░░░░░░░░░░░█████████░░███████████░░████
    ░░░░░░░░░░░░███████████████████████████░░░░░░██
    ░░░░░░░░░██████████████████████████████░░░░░░██
    ░░░░░░░█████████████████████████████████░░░░░░██
    ░░░░░██████████████████████████████████░░░░░░███
    ░░░░░███████████████████████████████████░░░░░████
    ░░░░████████████████████████████████████░░░░░████░░
    ░░░░███████████████████████████████████░░░░█████░░░
    ░░░░█████░░░░░░░░████████████████████░░░░██████░░░░
    ░░░░░██░░░░░░░░░░████████████████████████████░░░░░░
    ░░░░░░░░░░░░░░░░░██████████████████████████░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░████████████████████░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░█████████████░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░████████░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░████████░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░██░░░░░░░███████░░░░░░█████████░░░░░░░░░
    ░░░░░░███░░░███████░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░███████████░░░░░░░░░░░░░░░░░███░░░░░░░░░░░░░
    ░░░████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░████░░░░░░░░░░░░░░░░░░░░░░░░░░██████░░░░░░░

    yP71cHI.gif

    Xxkr2il.jpg
    56JtqQq.jpg
    kJFRh1a.png
    MOBO: MSI Z87M GAMING
    CPU: Intel® Core™ i7-4770K OC'd @ 3.7 GHz
    GPU: EVGA GTX 660 Ti
    RAM: Ripjaws X 8GB (2 x 4GB) DDR3 2133MHz
    OS: Windows 10 Technical Preview

  • It doesn't happen if I create a game, just when joining a game.
  • ScurvyScurvy Members
    Just tried it. Seems to be the same. Creating the game works fine, but joining leads to a crash. 
  • SpirrwellSpirrwell That Guy That Knows Things About a Lot of Things PVKII Team, Authorized Creator
    Alright, I just pushed some fixes to Steam for PVK2's Mac version, please let me know if it stops crashing.
    5GY1DFV.png


    ░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░████████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░██████░░░░██░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░░░████░░█████░░░██
    ░░░░░░███░░░░░░░░░░░░░░████░░█████░░░███
    ░░░░░░░░░░░░░░░░░░░░░░░░██░░░░░░████░░█████░░░████
    ░░░░░░░░░░░░░░░░░░░█████████░░███████████░░████
    ░░░░░░░░░░░░███████████████████████████░░░░░░██
    ░░░░░░░░░██████████████████████████████░░░░░░██
    ░░░░░░░█████████████████████████████████░░░░░░██
    ░░░░░██████████████████████████████████░░░░░░███
    ░░░░░███████████████████████████████████░░░░░████
    ░░░░████████████████████████████████████░░░░░████░░
    ░░░░███████████████████████████████████░░░░█████░░░
    ░░░░█████░░░░░░░░████████████████████░░░░██████░░░░
    ░░░░░██░░░░░░░░░░████████████████████████████░░░░░░
    ░░░░░░░░░░░░░░░░░██████████████████████████░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░████████████████████░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░█████████████░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░░░░░████████░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░░░░░░░░░░░░░████████░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░░░░██░░░░░░░███████░░░░░░█████████░░░░░░░░░
    ░░░░░░███░░░███████░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░░░███████████░░░░░░░░░░░░░░░░░███░░░░░░░░░░░░░
    ░░░████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
    ░░████░░░░░░░░░░░░░░░░░░░░░░░░░░██████░░░░░░░

    yP71cHI.gif

    Xxkr2il.jpg
    56JtqQq.jpg
    kJFRh1a.png
    MOBO: MSI Z87M GAMING
    CPU: Intel® Core™ i7-4770K OC'd @ 3.7 GHz
    GPU: EVGA GTX 660 Ti
    RAM: Ripjaws X 8GB (2 x 4GB) DDR3 2133MHz
    OS: Windows 10 Technical Preview

  • ScurvyScurvy Members
    I just tested it on my computer. Looks like it's all better! Thanks so much, I really appreciate the quick response and help!
  • Also works for me now, thanks! You really helped 🙂
Sign In or Register to comment.