[Workshop] Can't Disable Mods

DrAntagonistDrAntagonist Senior
edited November 2016 in Bugs/Support
If a mod looks interesting, I subscribe to it and then leave it in my list disabled if it conflicts with other things, so I can easily toggle which mods I have without having to redownload them. It worked just fine until yesterday when I downloaded an animation mod and found my game repeatedly crashing (I assume because I already had a shortsword model mod which also alters viewmodels, but I'm not sure) so I went to disable it, but it didn't disable. I kept trying to disable it, restarting, and finding it still on, then tested with a different mod to make sure it isn't just the animation mod. I uninstalled the animation mod, unfortunately, and am unable to disable any mods.

I searched for "Disable", "Workshop", and "Addon" in this subforum and couldn't find anything like this, so I hope I'm not wrong in posting it. If this is a legitimate issue and not just some fault of mine, I'll be willing to post any information to help fix it, but since I've never reported anything for PVK before I wouldn't know where to find anything. I looked around in the \pvkii\ directory for a bit but couldn't find anything like a crashlog.

Edit: Played for a few hours without crashing after unsubscribing from the animation mod, so I think that had to be the cause. This is also at the top of my addon page, just noticed it.


  • FelisFelis Glitch Kitty PVKII Team
    edited 12:49AM
    Something seems to be wrong with reading/writing the add-ons config, this can be a bug in the system.

    To help me debug this, run the game twice with these launch options: -condebug +_addons_debug 1 (right click pvkii in library -> set launch options). This will generate a console.log file in the pvkii folder, you can post it here or send a PM. Remember to remove the launch options when you're done.

    After that you can delete or rename your "addons.txt" file which is located in "pvkii" dir. This will refresh the config and should fix most problems, but resets the load order and disabled status.
  • DrAntagonistDrAntagonist Senior
    edited November 2016
    Hm, for some reason I can disable every mod except for Lord B's Shortsword Animations and Viceroy Devastator. I ran the game and exited it twice with the launch options "-noborder -window -condebug +_addons_debug 1". I sent it to you in a PM.

    Edit: Renaming my addons.txt to addons1.txt fixed it, thanks! I just have to go through the big list and right click on them all now. If only double-left click would toggle their state.

    Double edit: I thought it did, but I guess I thought wrong. I still can't disable them.

    Triple edit: Even if I go into addons.txt and manually change the 1 to a 0 it still is enabled when I launch.
  • FelisFelis Glitch Kitty PVKII Team
    edited 12:49AM
    Thanks, found out the cause for the bug. It's a parsing error caused by the use of control characters in add-on names. The quotes in "Viceroy Devastator" broke the system. :icon_stabhead:

    I'll put a hotfix for this as soon as I can.
  • El NegroEl Negro The Genuinely Only Sane Person Guests
    edited 12:49AM
    I've renamed the "Viceroy Devastator" so it has no quotes, not just because this will fix that bug (hopefully) but also because that's not how I wanted to name it, after all the other 'weapon mods' of mine don't have any quotation despite having their own unique name (Such as The Warchief)
    I make mods.
    Your soul cannot be saved.
    Like my mods and think I deserve something? It's always money, you can pay me up on PayPal using this e-mail; TheSandhog@outlook.com
    Or just use this link; https://www.paypal.me/TheSandhog

Sign In or Register to comment.