FPS Stutter / Lag (Dual core CPUs) and Crash / Freeze (Dual/Quad core CPUs) - Fix

HaVoKHaVoK PVKII Team
edited February 2010 in Bugs/Support
For those of you with dual core CPUs (2 cores) that are getting frame stutter / lag try the following, it might also help those of you with multicore systems who crash/freeze.

Disable Multicore rendering through cvar command
(Since we don't have it working in the advanced video options at the moment)

While in the PVKII Menu, open the console with ~
(if it doesn't open go to options, keyboard, advanced and then check "Enable developer console")

type mat_queue_mode 0 to turn multicore rendering off.
(mat_queue_mode -1 to turn it on which is default)

You can also add this to an autoexec.cfg


=========================================================


Or you can follow the steps below, but it's much easier to do the above.

Try setting hl2.exe's affinity to one core only once pvkii is open, if you don't know how, read below:
(Make sure when you do this, you're not in a server already, you might cause reflective surfaces that use cubemaps to have a pink checkered look and then you'd have to restart the game)

Start PVK II, alt tab out of the game then ctrl+alt+delete and select task manager. (Or start, run, type task manager)

Go to the processes tab, scroll down the list to hl2.exe, right click on hl2.exe and select "set affinity"

After select affinity is selected a dialog box will appear with the two CPUs, uncheck one of them, click okay, close task manager.

You're done for now, maximize PVK II and try playing and see if it lags.

If this works, you'll have to do it each time you start the game.

Hopefully it should fix it for most of you.

XVAAG.gif

Comments

  • zinho_92zinho_92 Senior
    edited 6:39AM
    Tried that, still no progress sad.gif . If i create a server and play without any other players it works just fine. But whenever i join a server i lagg, even if my ping is below 50 ! Please, any suggestions on what this could be and how i can fix it? thanks...
    The proof is in the pudding...
  • epilogueepilogue Senior
    edited 6:39AM
    Yeh that solution doesnt work for me either sad.gif
  • NihiliusNihilius Senior
    edited 6:39AM
    I have a AMD Phenom II X4 955 Processor ~3.2ghz.

    I get FPS drops which did not happen in 2.2 and this fix does not work.
    image
    image
  • MastixMastix Senior
    edited 6:39AM
    Yea well I found out I can't use multicore on the first game I played and it crashed so I just set it to a Single Core.
    When there will be a hotfix so I can use mat_queue_mode 2 (Multicore)?
    icon_yarrpirate.gif
  • NihiliusNihilius Senior
    edited February 2010
    I mostly get the FPS drops in the Knights area on PVK_island and some other maps aswell.

    I also get it in the Vikings, and pirates area too. It seem to happen on the whole map.
    image
    image
  • LoneSoldierLoneSoldier Senior
    edited 6:39AM
    Here's a quick tip that will increase fps.


    1) Open Steam.
    2) Select the Games Tab.
    3) Navigate to Pirates, Vikings, and Knights II.
    image
    4)Select Properties.
    image
    5)A window should open, then select Set Launch Options.
    image
    6)A text box should open.
    7)In that text box write "-high".

    There you go, now pvk will automatically be set to the highest priority everytime it opens! biggrin.gif
    sig3d.png
    Join the Club
  • NihiliusNihilius Senior
    edited 6:39AM
    Adding "-high" didn't fix anything for me. I hope they fix this issue soon, I really loved PVK II but now I am starting to play it less due to the drop in FPS.
    image
    image
  • JT_StephensJT_Stephens Senior
    edited 6:39AM
    I really hope there's an official fix in the works, as disabling half my processing power is a huge detriment to enjoying the game. sad.gif
  • a22a22 Senior
    edited 6:39AM
    I'm new to the game and I'm enjoying it, but this sudden FPS drop keeps happening to me too and has got me killed quite a few times and my computer should be very well capable to handle source games, have not experienced this in any other game and I do have dual core
  • epilogueepilogue Senior
    edited 6:39AM
    Yes can we please see an official fix? I would love to be able to run this fine on dual core.
  • CrackaPollyCrackaPolly PVKII Team, Authorized Creator
    edited 6:39AM
    It is Valve's engine, when they fix it and port it to the sdk we will be able to fix it.
  • NihiliusNihilius Senior
    edited 6:39AM
    Ah, feck it then.
    image
    image
  • NihiliusNihilius Senior
    edited February 2010
    I played PVKII earlier today and tried "mat_queue_mode 2" and it increased the FPS but, whenever I go to the area which has most of the action it crashes and freezes causing me to have to alt+tab and ctrl+alt+del to get out of PVKII.
    image
    image
  • NihiliusNihilius Senior
    edited 6:39AM
    Doe anyone have any idea why this happens and if there is a fix?
    image
    image
  • auto tragicauto tragic Senior
    edited April 2010
    I love this game to pieces, and have had nothing but enjoyable experiences in the past. However, my comp suffers from extreme stutter issues with this version of the game (none with any other games, like Crysis and Age of Empires 3) and it's really awful cause this game is the shit. If there's anybody out there that can offer a solution (I tried all suggestions already posted in this thread), please point it out for me. Thanks in advance
  • CrackaPollyCrackaPolly PVKII Team, Authorized Creator
    edited 6:39AM
    QUOTE (auto tragic @ Apr 16 2010, 04:39 PM) »
    I love this game to pieces, and have had nothing but enjoyable experiences in the past. However, my comp suffers from extreme stutter issues with this version of the game (none with any other games, like Crysis and Age of Empires 3) and it's really awful cause this game is the shit. If there's anybody out there that can offer a solution (I tried all suggestions already posted in this thread), please point it out for me. Thanks in advance


    What is are your computer specs?
  • M1ghtym1ckM1ghtym1ck Senior
    edited 6:39AM
    I dont know if there was a recent update.. but since a week or 2 I have the same problem... it runs absolutely fine on highest settings then every now and then it fridgeING drops my frame rate to 5 or so and I get killed.....
    it pisses me off so much I tryed EVERYTHING.
    ATI Sux
  • edited 6:39AM
    Don't worry, just play zps.
































    WITH ME
  • M1ghtym1ckM1ghtym1ck Senior
    edited 6:39AM
    oke I found out what is causing my lag....when a berserker uses his rage it instantly starts lagging like shirley.. when the berserker dies.. its over.

    its since the latest update....
    please fix this:(
    ATI Sux
  • QuantumQuantum Senior
    edited 6:39AM
    QUOTE (Nihilius @ Feb 15 2010, 11:19 AM) »
    I have a AMD Phenom II X4 955 Processor ~3.2ghz.

    I get FPS drops which did not happen in 2.2 and this fix does not work.


    I have this processor too, and the game freeze for ~0.5 secs. often..like at 1-1.5 minutes
    image
  • .sverek.sverek PVKII Team, Authorized Creator
    edited 6:39AM
    I don't know if it helps, but I run task manager and set HL2(PVKII).exe high priority. It helps me to avoid annoying slight lag, which might be caused by ping...

    http://dl.dropbox.com/u/11068560/ovju.jpg
  • frankjaegerfrankjaeger Senior
    edited 6:39AM
    Never have performance issues, but I have nonstop "hl2.exe has stopped working" crashes. Tried every mat_queue_mode setting and none seem to help. Any ideas?

    i5 2500k
    GTX 570
    8 GB RAM
    Windows 7
  • ugubaluguugubalugu Big Noob Senior
    edited October 2012
    The game will usually crash, if you use a "mat_queue_mode", which is not the default one. (Multicore rendering is doesn't work.)
  • frankjaegerfrankjaeger Senior
    edited 6:39AM
    According to OP the default is -1, which has it on? Either way, I still get crashes with it set to -1 or 0. No particular in-game event seems to set it off, it just happens after 1-10 minutes of gameplay.
Sign In or Register to comment.