Preparing To Launch -> White screen 1 sec -> Crash

MuuhMuuh Senior
edited December 2010 in Bugs/Support
Hi.

So, I downloaded PVK II today, and it ran great. But since I minimize a lot due to multitasking, I figured it would be alot easier to do the "-noborder -window" in launch options, as I've done with all my other Source-related games. Since I did that, whenever press Play Game on steam, it comes up with the Preparing to launch, then it's like it opens a window for 1 sec, and then it just disappears. No errors, no nothing. I've tried re-installing, defragging cache, checking files .. Nothing helps.

What can I do about this? I've also tried restarting steam serveral times after re-downloading/installing the game.


Edit:

Solution to this current problem: Add -autoconfig to the Launch Options.

( search tips: Source HL2 MOD PVKII crash on start-up whitescreen )

Comments

  • J-coJ-co Tramp Senior
    edited 3:20AM
    Does normal window mode work (with borders)?
    guitarsmallb.jpg
    I have an aristocratic smile and like to punch people
  • MuuhMuuh Senior
    edited December 2010
    No idea. can't even open the game anymore, even if i remove all launch options. Can't start it up.

    The funny thing is it worked fine, untill I changed the launch options. And now, no matter what I do, I can't get it to start up.
  • J-coJ-co Tramp Senior
    edited 3:20AM
    That calls for another clean re-install, you might also check source sdk base (and episode 2?)
    guitarsmallb.jpg
    I have an aristocratic smile and like to punch people
  • MuuhMuuh Senior
    edited December 2010
    Alright. I deleted the game, including the left-over files from the folders in the directory.

    I'll report back in a few minutes when I've redownloaded and installed it again.

    Thanks for your help :]

    Edit: Still exact same problem. I've also tried re-starting my computer. :\ I really wanted to play this Mod, it's awesome.
  • .sverek.sverek PVKII Team, Authorized Creator
    edited December 2010
    J-co, please don't suggest people to reinstall their games. They waste their time and just reinstalling game doesn't solve the problems. If you don't know what problem is, please stop randomly telling people what to do.



    @Muuh
    Sorry, let's 1st figure what your console trying to say.

    In properties after your "-noborder -window" add -condebug. So it will look like this
    CODE
    -window -noborder -condebug


    Now console will output log. Check your steamapps\xxx\pirates, vikings, and knights ii\pvkii folder and find console.txt
    Paste all what it says here.

  • J-coJ-co Tramp Senior
    edited 3:20AM
    I'll probably stay out of this subforum then
    guitarsmallb.jpg
    I have an aristocratic smile and like to punch people
  • MuuhMuuh Senior
    edited December 2010
    I've added the -condebug command, but it does not produce a console.txt file in my pvkii directory.

    Edit: Just for the heck of it, I'll post my systeminformation. And yes, all drivers is updated to latest version

    Processor: AMD Phenom™ II X6 1055T Processor (6 CPUs), ~2.8GHz
    Memory: 4096MB RAM
    DirectX Version: DirectX 11
    Card name: ATI Radeon HD 5700 Series
    Manufacturer: ATI Technologies Inc.
    Chip type: ATI display adapter (0x68B8)
    Driver Version: 8.791.0.0
  • .sverek.sverek PVKII Team, Authorized Creator
    edited 3:20AM
    it works for me, please recheck. Also add -dev, so I we check more info.

    CODE
    -window -noborder -condebug -dev


    that's my launch option. And I get console.txt in C:\Program Files (x86)\Steam\steamapps\dark_sokol\pirates, vikings, and knights ii\pvkii (my case)
  • LucasLucas Walter White Members
    edited 3:20AM
    If i am right there was a command that cleaned all earlier commands as if they never been written, i think.
    Tschoppo wrote:

    hello dear, said banana pie, but all of a sudden it came to life.
  • MuuhMuuh Senior
    edited December 2010
    Even if I copy-paste your launchoptions into my game, it still doesn't work. It won't produce the Console.log file. I tried to input it into my Counter-Strike: Source launch options, and it does start up and produce the Console.log file, so I'm sure it's all typed in perfectly in the launch options.

    Here's the CSS log, if it's of any help what so ever.. *sigh*
    CODE
    CSoundEmitterSystem:  Registered 838 sounds
    CResponseSystem:  scripts\talker\response_rules.txt (15 rules, 76 criteria, and 16 responses)
    maxplayers set to 32
    Heap: 256.00 Mb
    Steam config directory: c:\program files\steam\steamapps\(AccountName)\counter-strike source\platform\config
    Parsed 362 text messages
    [Cloud]: SUCCEESS retrieved cfg/config.cfg from remote storage into cfg/config.cfg
    execing config.cfg
    Unknown command "cl_thirdperson"
    cc_lang =
    Not playing a local game.
    [Cloud]: SUCCEESS retrieved materials/vgui/logos/spray.vtf from remote storage into materials/vgui/logos/spray.vtf
    [Cloud]: SUCCEESS retrieved materials/vgui/logos/spray.vmt from remote storage into materials/vgui/logos/spray.vmt
    Sound Initialization: Start
    DS:headphone configuration detected
    Set primary sound buffer format: yes
    Using secondary sound buffer
       2 channel(s)
       16 bits/sample
       44100 samples/sec
    DirectSound initialized
    Sound Initialization: Finish, Sampling Rate: 44100
    6 CPUs, Frequency: 2.8 Ghz,  Features: AuthenticAMD SSE SSE2 MMX 3DNow RDTSC CMOV FCMOV
    Steamworks Stats: Requesting CLIENT session id.
    execing valve.rc
    Steamworks Stats: Received CLIENT session id: 661202035
    [Cloud]: SUCCEESS saving cfg/config.cfg in remote storage
    [Cloud]: SUCCEESS saving materials/vgui/logos/spray.vtf in remote storage
    [Cloud]: SUCCEESS saving materials/vgui/logos/spray.vmt in remote storage
    Host_WriteConfiguration: Wrote cfg/config.cfg
    0:Stopped sound ui\buttonclickrelease.wav
    Steamworks Stats: Ending CLIENT session id: 661202035
    Unable to remove c:\program files\steam\steamapps\(accountName)\counter-strike source\cstrike\textwindow_temp.html!
    CreateEvent: event 'server_shutdown' not registered.
    Shutdown function ShutdownMixerControls() not in list!!!
  • .sverek.sverek PVKII Team, Authorized Creator
    edited December 2010
    well, it means your PVKII doesn't even launches, so it can't even start to write console. So it means there strong abort on dlls. Nothing wrong with cs:s log. So there critical stop on PVKII.

    Have you tried launching game in full screen? If we can't even get console to say what's going wrong, there little chance we can narrow problem down.
  • .sverek.sverek PVKII Team, Authorized Creator
    edited December 2010
    http://forums.pvkii.com/index.php?showtopi...mp;#entry191601

    maybe could try allowing access for dlls, if you are not admin etc... But I am only suggesting it. Need someone with similar experience for help.

    more for potential help > https://support.steampowered.com/kb_article...=9416-WUCV-4502
  • AkzAkz PVKII Team
    edited 3:20AM
    You could try removing the 'SteamApps\username\pirates, vikings, and knights ii' folder. That should reset all the configs.
  • MuuhMuuh Senior
    edited December 2010
    Well as I stated earlier, even with an empty Launch Options, I cannot get it to start?

    I've filmed it, so you can see for yourself what happens.

    [Link Incomming once uploads done - 45 mb - Flash movie] :: http://www.megaupload.com/?d=WF7W2PBL ::


    I have checked the .dll settings, and they're all fine.

    The game also ran perfectly, untill I changed the launch options.

    Will try to delete the directory, and return with results.

    Edit--

    Tried to delete the folder, and run the game twice, with and without the launchoptions. Still not working, although I can see on steam it puts me as In-game in PVKII, and the hl2.exe process starts up for a sec, but then disappears. When I press play on Steam it also increases in CPU usage, to it's starting it up. But it's still not creating the console.log ..

    Thanks for trying to help me guys, it's really appreciated :]
  • .sverek.sverek PVKII Team, Authorized Creator
    edited December 2010
    I suggest to delete again 'SteamApps\username\pirates, vikings, and knights ii' folder and restart pc. I think there some simple detail missing (moved by accident cache file etc...)
  • MuuhMuuh Senior
    edited December 2010
    Okay. I'll delete it and restart. I'll post back in 5 minutes (not the fastest PC, with all the crap I got on it)

    Edit:--

    Okay, so .. That didn't work either.

    I haven't touched any files. I installed it, played for 10 mins, closed it down to change launch options and did so, and then it wouldn't work.

    No clue on what went wrong.
  • AkzAkz PVKII Team
    edited 3:20AM
    Try adding -autoconfig to the launch options.
  • MuuhMuuh Senior
    edited December 2010
    It worked!

    The game now runs in windowmode without a border.

    Thank you so much, all of you!

    - It also did generate the console.log, finally.

    CODE
    CSoundEmitterSystem:  Registered 513 sounds
    CResponseSystem:  scripts\talker\response_rules.txt (54 rules, 49 criteria, and 54 responses)
    maxplayers set to 24
    Heap: 256.00 Mb
    KeyValues Error: LoadFromBuffer: missing { in file
    (*Scheme*), (*CustomFontFiles*), (*1*), (*russian*),
    Steam config directory: c:\program files\steam\steamapps\(accountName)\pirates, vikings, and knights ii\platform\config
    Parsed 26 text messages
    Parent cvar in client.dll not allowed (hud_showtimers)
    Convar sv_community_grouptag has multiple different change callbacks
    Parent cvar in client.dll not allowed (cl_motionblur)
    Type teleport_countdown_screen of meta class teleport_countdown_screen undefined!
    MetaClass missing for teleport_countdown_screen
    Couldn't find custom font file 'resource/HL2MP.ttf'
    ConVarRef hud_saytext doesn't point to an existing ConVar
    ConVarRef hud_saytext doesn't point to an existing ConVar
    ConVarRef spec_drawstatus doesn't point to an existing ConVar
    Hud element 'CHudGameMessage' doesn't have an entry 'HudGameMessage' in scripts/HudLayout.res
    material "vgui/gfx/vgui/draw" not found.
    --- Missing Vgui material VGUI/gfx/VGUI/draw
    material "vgui/gfx/vgui/pirateswin" not found.
    --- Missing Vgui material VGUI/gfx/VGUI/pirateswin
    material "vgui/gfx/vgui/vikingswin" not found.
    --- Missing Vgui material VGUI/gfx/VGUI/vikingswin
    material "vgui/gfx/vgui/knightswin" not found.
    --- Missing Vgui material VGUI/gfx/VGUI/knightswin
    material "hud/tooltip_bg" not found.
    --- Missing Vgui material HUD/tooltip_bg
    FMOD initialized
    Could not find screen space effect pvk2_objglow
    material "vgui/classicons/sharpshooter" not found.
    --- Missing Vgui material vgui/classicons/sharpshooter
    material "vgui/classicons/manatarms" not found.
    --- Missing Vgui material vgui/classicons/manatarms
    execing config_default.cfg
    Host_WriteConfiguration: Wrote cfg/config.cfg
    Sound Initialization: Start
    DS:stereo speaker configuration detected
    Set primary sound buffer format: yes
    Using secondary sound buffer
       2 channel(s)
       16 bits/sample
       44100 samples/sec
    DirectSound initialized
    Sound Initialization: Finish, Sampling Rate: 44100
    6 CPUs, Frequency: 2.8 Ghz,  Features: AuthenticAMD SSE SSE2 MMX 3DNow RDTSC CMOV FCMOV
    Touched 0 cached files
    Touched 0 cached files
    Touched 0 cached files
    execing valve.rc
    execing autoexec.cfg
    CAchievementMgr: Requesting Current UserData for, 17570
  • .sverek.sverek PVKII Team, Authorized Creator
    edited December 2010
    Yay! hope it keep working nicely biggrin.gif

    gonna add more details to post, so more people can come to our forums for help.
  • edited 3:20AM
    might want to blur out ur steam username
    image
    image
  • .sverek.sverek PVKII Team, Authorized Creator
    edited 3:20AM
    after replacing motherboard, cpu and installing 2 monitors I run into this problem myself. Game won't even output console or whatsoever.

    Akz's method of using -autoconfig worked perfectly.

    However TF2 working fine for me without applying -autoconfig.
  • anemoneanemone Senior
    edited 3:20AM
    um can't you change to open in window or non window via steam? and sounds like a solution has been found smile.gif great, someone remember it for anyone that gets it ever again. biggrin.gif
    casper.s2

    image
    kinship is open for boarding,

    sign the board and let flotsam become .s2

    http://forums.pvkii.com/index.php?showtopic=12155


    the uncurstable; the untouchable— alliance, coalition, syndicate, kinfolks.... coterie



    s2 'You'
Sign In or Register to comment.