Invisible Archer!!!!! Really Want to Fix This :/

GatekeeperGatekeeper Senior
edited 6:22AM in Bugs/Support
Ive played this game since 2.1 or whatever, and Ive had to delete the game many times, so i have always been downloading the most updated version.

though they're hasn't been a time that the Knights Archer wasn't partially invisible to me!!!!

You can always see his weapon, and little splotches of his body, but majority of his body is invisible. It isn't crucial but it is very annoying, id like to enjoy seeing him instead of nearly missing him.

Does anyone have a solution to this?

my guess is that im missing textures or something, but ive downloaded PVKII many times, from many locations and its always like this...

Comments

  • CrackaPollyCrackaPolly PVKII Team, Authorized Creator
    edited 6:22AM
    What video card do you have?
  • GatekeeperGatekeeper Senior
    edited 6:22AM
    an Nvida Quadro NVS 280 SD, the game runs great though, and i also ran it once on a friends PC who has insane hardware and the archer was still screwed up, hope some1 can help me.

    If need be i can Screenshot the archer n try to see what it says in console n post it
  • CrackaPollyCrackaPolly PVKII Team, Authorized Creator
    edited 6:22AM
    Well what dx level does it say in the options menu. I think its a problem only on dx7 hardware. I couldn't find directx info on your card online search tongue.gif
  • PeepeewilsonPeepeewilson PVKII Team
    edited 6:22AM
    I'm not certain if this will work but try moving the archer.mdl file out of the pvkii/models folder and connecting to a server. Your PC should try to re download the missing model. Also check the dxlevel in console by typing in dxlevel and looking for what it is defined as. I would just go ahead and post some screenshots as well. Preferably one showing the model and one showing the error lines you are getting in your console.
  • EinEin Child Protection Services Senior
    edited 6:22AM
    Had the same problem on my old pc - It has to do with the Video card you're using.
    I got a new pc.
  • GatekeeperGatekeeper Senior
    edited 6:22AM
    thats bullshit, there should be a fix, all the other models work FINE
  • GatekeeperGatekeeper Senior
    edited 6:22AM
    QUOTE (Peepeewilson @ Apr 17 2009, 05:08 PM) »
    I'm not certain if this will work but try moving the archer.mdl file out of the pvkii/models folder and connecting to a server. Your PC should try to re download the missing model. Also check the dxlevel in console by typing in dxlevel and looking for what it is defined as. I would just go ahead and post some screenshots as well. Preferably one showing the model and one showing the error lines you are getting in your console.


    hey i tried removing the .mdl file, but it just made all the archers turn into the word ERROR in big bold red letters lol. I have some screenshots of it now, but i cant figure how to upload them. Does this Upload Attachments thing below work for images?
  • ZinuXZinuX Mutated Walrus Hamster Members, Beta Tester
    edited 6:22AM
    Try Photobucket, and upload it there wink.gif
    dragonattacksig04.pngrage.jpg
  • GatekeeperGatekeeper Senior
    edited 6:22AM
    QUOTE (Z!nuX @ Apr 17 2009, 08:56 PM) »
    Try Photobucket, and upload it there wink.gif


    yeah except i dont have a photobucket, and i dont really want to sign up for one :/
  • ZinuXZinuX Mutated Walrus Hamster Members, Beta Tester
    edited 6:22AM
    Well, if you don't do it, then i can't help you


    Just Register wink.gif
    dragonattacksig04.pngrage.jpg
  • GatekeeperGatekeeper Senior
    edited April 2009
    HERE IS THE MAIN ERROR, IT HAS ALWAYS BEEN THIS WAY FOR ME! You say you will help me so help me!

    image



    HERES WHAT HAPPENED WHEN I REMOVED THAT MDL. FILE LIKE YOU SAID HAHA, I JUST PUT THE FILE BACK THOUGH

    image
  • PeepeewilsonPeepeewilson PVKII Team
    edited 6:22AM
    QUOTE (GodlessPirate @ Apr 17 2009, 10:39 PM) »
    HERES WHAT HAPPENED WHEN I REMOVED THAT MDL. FILE LIKE YOU SAID HAHA, I JUST PUT THE FILE BACK THOUGH


    Yes that is why I didn't tell you to delete it entirely. Judging from your texture quality you have a low spec video card. It would be very beneficial to look deeper into this directx theory. I'm going to research your card and see what I can come up with. Go into a game and type dxlevel into console, hit enter and it will tell you what level your directx is running at. Post that here please.
  • GatekeeperGatekeeper Senior
    edited April 2009
    yeah ive tried that already a bit, it runs in dx7, but ive tried changing it to dx9(which is what the PC has) and dx8 but still no archer, and the console just says something about the shader. Every other character works great though, just that damn archer.

    I dont understand why if every other character but the archer is fine, why it would be a vidcard problem?

    i appreciate the help
  • mrmongmrmong Senior
    edited 6:22AM
    your videocard could be damaged, try some other 3d games and see if they have rendering errors.
  • PeepeewilsonPeepeewilson PVKII Team
    edited April 2009
    QUOTE (mrmong @ Apr 18 2009, 05:11 PM) »
    your videocard could be damaged, try some other 3d games and see if they have rendering errors.


    That is very unlikely simply because he renders the rest of the game fine. I think there is something different about the way the archer model renders that conflicts with his video cards shader model. This may be an unfixable problem unless you buy a new video card or computer all together. sad.gif

    For now all I can think of is try updating drivers/directx etc.
  • gubbegubbe Senior
    edited 6:22AM
    new drivers for your video card might do the trick.. I'd try it.
Sign In or Register to comment.